Captcha background not well generated when using of a CrystalizeFilter

Description

After a lot of page refreshments, the captcha background generated by using a CrystalizeFilter is always a black form instead of a mist of points.

Here is the Crystalize filter declaration:

<!-- ************ FILTER declaration ************ -->

<bean id="crystal" class="com.jhlabs.image.CrystalizeFilter">
<property name="scale" value="0.5" />
<property name="gridType" value="1" />
<property name="fadeEdges" value="false" />
<property name="edgeThickness" value="0.4" />
<property name="randomness" value="1.0" />
</bean>

<bean id="cristalDef" class="com.octo.captcha.component.image.deformation.ImageDeformationByFilters">
<constructor-arg index="0">
<list>
<ref bean="crystal"/>
</list>
</constructor-arg>
</bean>

Here is the word 2 image declaration:

<!-- ************ WORD 2 IMAGE declaration ************ -->

<!-- Constructs a WordToImage, which assemble components: a font generator,
a background generator, a paster and deformations: the fist one deform the
background only (none is the "null" deformation, which does nothing) the
second one deform the text only (none is the "null" deformation, which does
nothing) the third one deform the hole picture -->
<bean id="wordtoimage" class="com.octo.captcha.component.image.wordtoimage.DeformedComposedWordToImage">
<constructor-arg index="0" ref="fontGenRandom" />
<constructor-arg index="1" ref="backGenUni" />
<constructor-arg index="2" ref="simpleColoredPaster" />
<constructor-arg index="3" ref="cristalDef" />
<constructor-arg index="4" ref="none" />
<constructor-arg index="5" ref="none" />
</bean>

Environment

Java: jdk1.6.0_19
OS: Windows XP Pro SP3

Assignee

Unassigned

Reporter

Jean-Louis Rigau

Labels

None

Components

Affects versions

Priority

Major
Configure